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This manual introduces Crystal XE software interface and its main features. It 
demonstrates the basics of using Crystal XE. 
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I. INSTALLATION 

1. Installation 

If Crystal XE is preinstalled on your computer, the default directories are the following: 
 Program directory: c:\riber\CrystalXE 
 Project directory: d:\riber\<Project name> 

 
To download the latest version of Crystal XE, you need to create your account on 
http://www.crystalXE.com. After receiving the activation confirmation, go in MY CRYSTAL 
XE and download the setup program. 
 
Run the setup program and follow the installation instructions (select the demo files) in the 
dialog box to complete the installation. 
 
In Crystal XE, a project corresponds to the directory name in which you can find the data 
files specifying your application (configuration file, synoptic, security files etc.). 
 
A Crystal XE shortcut icon should be available on your desktop. If not, create the shortcut 
from the ‘CrystalXE.exe’ file located in the directory c:\riber\CrystalXE. 
 

2. License key 

To benefit from all the features of the software, a license key will be required at the time of 
the execution of the application. You can skip this step for demo. In demo mode, only 
communications with devices are disabled, all other features remain available. 
 
To receive your license key, note down your software information and send it to RIBER 
customer service to the indicated email address. 
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II. SETTINGS 
 

 
 
Click on the Setup menu to display the drop-down menu or click on the following icon in the 

top right-hand corner of the interface . 
 

3. Hardware configuration 

Click on the Hardware configuration submenu. 

In the menu  or on the setup button  

 

 You cannot modify the hardware configuration when a recipe is executing. 
 
Crystal XE comes with a library of equipment and devices. 
For each chamber (sub-system), click Equipment or Devices (left) to display the available 
items palette (right). 
 

 

Library 

Chamber 
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Add or modify equipment and devices 
Drag and drop the equipment and devices from the palette directly to the equipment tree 
structure or to the devices graphical view. 
 

    
Adding equipment     Adding devices 

 
To be operational, a sub equipment must be linked to a device and conversely, in order for 
Crystal to communicate with a device, the module must be linked to a sub equipment. 
To link sub equipment to a device, click on the desired sub equipment name in the 
equipment tree structure and select the device and the channel to be linked with from the 
drop-down menu. 
 

 
 

 When a sub equipment is not linked to a device, it is displayed in italic gray. 

Simulation mode 
 
Switch from Online mode to Simulation mode, and conversely, by moving the following 
switch: 
 

 

Drag and drop Equipment 

Drag and drop devices 
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 You must have a valid license to switch to the online mode. 
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4. Options 

The Options dialog allows you to configure Crystal XE software. 
 
You can configure the software even if a recipe is currently executing. 
 

 
 

 For more details, refer to the user manual. 
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5. Users 

The Users submenu, allows you to manage the different users and their permissions. 
 
You systematically need to enter a password to open the Users administration window. 
 

 
 
The default password is ‘admin’.  
You can change the password by clicking on the Change admin password button, in the 
bottom left-hand corner of the window. 
 

 
 
In this window, you can add new users, you can associate a user to a group of user and 
chambers. You can also create new group of users and change the rights of each group. 
 

You can also open the Users administration window by right-clicking on the User icon  
located in the top left-hand corner of the main interface, and selecting Manage Users. 
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III. BACKUP 
 

 

 
 
To save the configuration of your current project and clone the software to another 
computer, click on the File menu and select Backup. 
 

 
 
You can choose specific files to be saved by checking the corresponding boxes. 
 

 If you check the Records or Black box (if available) boxes, large files might be 
generated. 
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IV. INTERFACE OVERVIEW 
 

 
 

ICONS 

 

Main tab Chamber tabs 

 

Main interface 

Event history 

 
Event notification mode 

 

 

Setup button 
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1. Icons overview 

1.1 User icon 
 
Click on the following icon to display the list of users and log in  
(if user restrictions are enabled) 
  

 
The following icon indicates that you are logged in or that user restrictions are 
disabled  
 
You can open the Users administration window by right-clicking on the user icon and 
selecting Manage users. 

 
 

1.2 Simulator icon 
 
The following icon indicates that Crystal XE is operating in simulation mode. 

 
 
In simulation mode, all communications with peripheral devices are disabled and some 
values are simulated. 
 
You can switch from Simulation mode to Connected mode by checking the corresponding 
box in the Project configuration window, that can be accessed from the Setup menu > 
Hardware configuration. 
 

1.3 Alarm icon 
 
The alarm icon indicates that at least one alarm is activated. 
Click on the alarm icon to display all the alarms in a pop-up window.  
 



 
 

 ______________________________________________________________________________________  
Crystal XE - Getting started - rev 3 Page 12 of 48 
This document is Property of RIBER August 2019 

2. Event history 

The history area at the bottom of the interface displays all the recorded events. 
 

 
 
▫ You can choose to display only a specific event type using the filter tabs: 
 

 
 
 
 
 
 
 To delete the event history, right-click the history area and select Clear all logs (this 

does not delete the log file, this action only clears the display) 
 
 Double-click on any of the events to open the Log viewer and display event details 

Or right-click and select Open in a new window. 
 
Events are saved automatically as text files to the Log folder, in your project directory.  

 To open your project directory, click on the File menu and select Browse project directory. 

 

3. Event notifications 

These drop-down list boxes in the lower-right corner of the interface, allow you to define 
when you want to be notified by a pop-up window or an email alert (only available if email 
settings are defined in the options). 
 

 

All events: Enable email alerts / pop-up windows for all 
events (all alarms, user events, etc.) 
Critical and warnings: Enable email alerts / pop-up 
windows for critical level or warning level alarms 
Critical only: Enable email alerts / pop-up windows for 
critical level alarms only 
Never: Disable all email alerts / pop-up windows 
 

Use the corresponding drop-down list to select your choice. 

 The choice “Critical and warnings” is recommended. 

 The choice « Never » is not saved when exiting Crystal XE. 

 

 

 

Alarms related events Connection to devices Actions of the users 
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V. THE MAIN TAB 
 

 
 

1. Automation 

The Automation tab allows you to create, edit and execute production batches. 
 
A batch is used to organize each operation performed by the different parts of the epitaxy 
system, in parallel or in sequence. A "batch file" contains the description of the movements 
of the platens in the system. 
 
 For more details, please refer to the chapter Platens automation in this manual. 
 

2. User view 

The user view interface is a visual representation of the MBE system that allows you to 
monitor and control the operation of equipment. 
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The User view interface depends on your configuration. 

Example of equipment representation 
 
Cell Ga2_ABI85_P11 and its three pieces of sub equipment (insert, base and shutter) 
 

  
 
 
 
 
 
 
 
 
 
 
 
 
Click on the following button , from the desired sub equipment’s item, to open the Detail 
view window. 
 For more details about the Detail view, please refer to the chapter System view in this 
manual. 
 
Shutter  
 

 
 
 
The interface allows you to perform the following actions: 
 

 Opening / closing shutters    
 following the measured value     
 viewing the set point value    
 following the output power bar graph    
 opening the Detail view window   

Double click to change the status 

Detail view of tip temperature 

Detail view of base temperature 
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Interacting with the equipment 
 
Opening / closing shutters 
 

 

You can open/close a shutter by double-clicking on the 
desired shutter icon. 
Green icon indicates that the shutter is open while red icon 

indicates that it is closed. 

>> When you first click on the shutter icon, a progress bar 

appears over the icon . 
 
Double click before the time (yellow) is up. 

Customizing the User view interface 
 
Right-click on any part of the User view interface background and select “Edit the form” to 
open the Tool palette (left). 
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Moving items 
 
When the Tool palette is open, you can move any of the items directly from the interface.  
Click on the desired item, hold down the left mouse button and move it to another part of 
the interface. 
 
Press the keyboard arrow keys to move the selected item pixel by pixel on the grid. You 
can change grid options by right-clicking on the interface and selecting Grid options. 
 
Adding equipment or sub equipment 
 
Select the basic tab and drag and drop equipment in the user view. 
 

 
 
The equipment and sub equipment are listed in a tree view in the Tool palette in the basic 
tab. You can drag and drop the desired equipment and sub equipment directly to the User 
view interface. 
 
 Not all types of equipment have a user view representation. You might need to 

expand an equipment list in the tree structure and add sub equipment only.  
 
Example: to add a shutter, expand the cell item’s list (click on the ‘+’ sign), then drag and 
drop the shutter directly to the User view interface. 
 

Drag and drop 
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Deleting equipment or sub equipment 
 
When the Tool palette is open, you can remove any equipment or sub equipment from the 
User view interface: 
 
 select the desired item,  
 right-click to display the drop-down menu, 
 select Delete (or press Delete key on the keyboard). 

 

 
 

3. Security 

The Security tab allows you to enable or disable alarms for the system security agents. 
 

 
 
For example, after selecting the Memory Space security agent, you can set a 500 MB low 
threshold value from the Agent tab. An alarm will be activated as soon as the amount of 
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memory available drops under 500 MB. The Action tab allows you to configure alarm 
notifications (sound, email, SMS, etc.). 
 

VI. CHAMBER TABS 
 
On the right side of the Main tab, chamber tabs allow you to display chamber features. The 
number of visible chambers depends on your configuration. 
 
Click on the desired chamber tab to display the chamber’s menu. 
 

 
 

1. System view 

 
 
The System view interface displays all equipment in a list view (right) depending on your 
configuration. 
 
You can directly interact with some of the equipment’s from the list view (closing/opening 
shutters, modifying target set point values, etc.).  
 
Click on the desired equipment from the list view to display its associated Detail view 
window (left). 
 

 
List of equipment and their sub 

equipment 

Detail view of selected 
sub equipment 

Setup 

Tags list 

Selected equipment 
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1.1 Equipment list view 
Each line displays an overview of the equipment and all its associated sub equipment. 
 

Example: List view of the As_VAC500_P1 equipment and its four pieces of sub equipment 
(Cracker, Reservoir, Shutter, Valve): 

 

 

 
Alarm icon 
 
The alarm icon (bell), located on the left side of each piece of equipment, indicates the 
state of the equipment alarm: 
 

 Gray bell: the alarm is disabled 

 Green bell: the alarm is enabled 

 Red bell: the alarm is activated 
 
 
Interact with the equipment 
 
From the list view, you can directly modify some of the sub equipment parameters. 
 
Example: 

 opening/closing shutters    

 modifying the values    

 stopping a running linear ramp   
 
The editable fields and available features depend on the type of equipment and sub 
equipment. 
 
Customizing the list view 
 
 To change the equipment order, drag and drop the equipment directly from the 

interface to move it up or down. 
 
 To hide or display the equipment: 

Click and hold down on the equipment item to display the trash icon . 
To hide equipment, drag and drop the desired equipment item into the trash icon. 
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You can display all hidden equipment by right-clicking on any part of the interface and 
selecting View all hidden equipment. 
To display only specific equipment, right-click on any part of the interface, move the cursor 
over Show specific equipment and select the equipment to be displayed. 
 
The equipment reappears at its previous order. 
 

1.2 Example of Detail view window (temperature) 
 
The Detail view window displays all the configurable parameters of the sub equipment and 
allows you to follow and edit their values (when editable).  
 
Each type of equipment displays a specific Detail view window. 
 
Example: Detail view window of the Ga1_ABN60DF_P8 equipment with its three 
associated pieces of sub equipment (broken into three tabs): 
- Tip 
- Base 
- Shutter 
 

 
 
Click on the desired sub equipment tab to display the configurable parameters. 
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Setting maximum and minimum values 
 
Maximum and minimum value fields, such as maximum set point or maximum output 
power, are not directly editable. 
 
To set maximum and minimum values: 
 
 Select the desired chamber from the chamber tabs. 
 On the System view tab, select the desired equipment in the list to display the 

associated Detail view window. 
 Click on the Setup button , located in the bottom left-hand corner of the window, 

to open the Setup pop-up window and modify the parameters. 
 

 

 You will need suited user permissions to access this window. 
 
Automatic mode and manual mode 
 
The automatic mode consists of a regulation operated by the temperature controller which 
is associated with the equipment. In manual mode, the output power of the controller is 
directly used as the setpoint of the power supply. In manual mode, there is no regulation, 
the power is constant or follow a ramp. 
 
As for some types of equipment, you can switch the regulation mode from Automatic to 
Manual by double-clicking on the Regulation mode button: 
 

   
 
>> When you first click on the button, a progress bar appears  

Click again before the time (yellow) is up.  
 
If a linear ramp is running , you cannot switch the regulation mode.  

Stop the linear ramp  before switching the regulation mode. 
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 The Automatic mode allows you to specify a target set point value (°C) to be 
reached. Click on the Target SP field to type the desired value. 

 

 
 
 The Manual mode allows you to specify a constant power set point (%) to reach the 

required temperature. Click on the Target OP field to type desired value. 
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Step and linear ramp 
 
 Step: select Step from the drop-down list to directly set a target set point value (in 

Automatic mode) or a target output power value (in Manual mode). 
 

 
 
 Linear ramp: select linear from the drop-down menu to modify the temperature by 

programming a rise using a linear ramp until reaching the target set point value (in 
Automatic mode) or the target output power value (in Manual mode): 

 
           auto     manual 

 
Set the ramp slope    

   

 Select ‘Linear’ from the drop-down list  
      auto       manual 

 
Set a target set point    

   
 The ramp activity button is turned on (green) when a linear ramp is running 

 

 
 
 To stop a running linear ramp, turn off the ramp activity button  by double-clicking 

on it.  
>> When you first click on the button, a progress bar appears . 

Click again before the time (yellow) is up). 
 
 Other ramps (custom profiles) can be defined using the Options menu. 

 
Following in charts 
 
Right-click on a parameter’s value and select Follow in a chart to open the corresponding 
chart in a pop-up window. 
 

 
 
To save this chart, right-click on any part of the chart window, select File > Save as and 
then select the desired file format. 
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2. Chamber security 

 
 
The alarms management interface allows you to: 

 configure security agents for each type of equipment, 
 set an alarm for each security agent, 
 choose the action to be performed if the alarm is activated. 

 
 If one of the chamber’s alarms is activated, a red bell icon will appear over the 

chamber’s tab and the Security tab alarm icon will turn red as follows: 
 

 
 
 
 Bell icons indicate the state of the alarms as follows: 

 Gray bell: the alarm is disabled 

 Green bell: the alarm is enabled 

 Red bell: the alarm is activated 
 
 
 The security interface is divided into three parts as follows: 
- the equipment view (right), 
- the tree view (center), 
- the security agent management panel (left). 
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 Security agents panel Tree view Equipment view 
 

2.1 Equipment view 
The equipment view displays all the functioning equipment, depending on your 
configuration. 
 
Click on the desired equipment to highlight the equipment line in the tree view and display 
the associated security agents panel on the left side of the interface. 
 

  
 
 The bell icon indicates the state of the equipment’s alarm (enabled, activated or 

disabled). The equipment alarm is activated if at least one of the equipment’s security 
agents’ alarms has occurred. 

 
 The following circle icon  indicates that the equipment alarm has occurred. The 

digit indicates the number of times the alarm of the equipment occurred.  
For example, the following icon  indicates that the equipment’s alarm occurred four 
times. 
 
This icon will remain, even if there is no longer any activated alarm. 
 
Click on this icon to acknowledge the activation of the alarms. Once all alarms have been 

acknowledged, the icon will turn green . 
 

 You cannot acknowledge an alarm as long as the alarm is activated. 
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2.2 Tree view 
All the equipment and sub equipment alarms are visible in a tree view as follows: 
 
equipment > sub equipment > security agents 
 
Example: tree structure of the Si_ABN135D_P3 equipment 
 

 
 
 Si_ABN135D_P3 equipment with two pieces of sub equipment: 
- Temperature 
- Shutter 

 
 Temperature sub equipment with four security agents: 
- Communication fault 
- Minimum and maximum temperature 
- Out of range 
- Minimum and maximum power 

 
 In the tree structure, double-click (or click on the + / - icons) to expand / collapse a list. 

 
 You can choose to expand only the security agents whose alarms are disabled by 

clicking on the Expand disabled only tab: 
 

. 
 
You can also choose to expand the equipment level alarms only to have a quick view on 
the alarms’ state, by clicking on the Expand alarms only tab: 
 

. 
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2.3 Security agents management panel 
 

 
 
Each type of equipment displays a specific panel, located on the left side of the interface. 
 

 
 

Example: Si_ABN135D_P3 equipment 
 
The Equipment tab displays all sub equipment of the selected equipment. 
Click on one of the sub equipment tabs, to display the sub equipment’s security agents. 
 

 
 
In this example, the Temperature sub equipment has four security agents (Communication fault, 
Minimum and maximum temperature, Out of rang and Minimum and maximum power). 
 

2.4 Enabling/disabling alarms 
In the tree structure, right-click on the desired security agent and select Enable to enable 
the alarm (green icon) .  
Right-click and select Disable to disable the alarm (gray icon) . 
 
Or check/uncheck the security agents’ boxes in the Security agents panel to enable / disable the 
alarms as follows: 
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You can disable or enable alarms at the security agent level or at the sub equipment level 
in the tree structure.  
 

 You cannot disable alarm at the equipment level. 
 

 
 
If one of the security agents’ alarms is activated, the sub equipment alarm and the 
equipment alarm are activated. 
 
If the alarm of the sub equipment is disabled, all alarms of the sub equipment’s security 
agents are disabled as well. 
 

 The sub equipment level alarm must be enabled to allow you to enable its different 
security agents’ alarms. 
 

2.5 Configuring the security agents 
You can configure the security agents using the security agents management panel, 
located on the left side of the Security interface: 
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Click on the sub equipment tab and select desired security agent to display the settings 
below. The available settings depend on the type of the selected security agent. 
 
Agent 
 
The Agent tab allows you to set threshold values and configure the activation of the alarm. 
 
For example, using the Temperature security agent panel, you can specify minimum and 
maximum temperature values.  
 

 
 
In this example, if the temperature value drops below 500 °C or exceeds 1500 °C for 

5 seconds (filter), the alarm will be activated . 
 
The current value of the parameter is displayed bellow. 
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Action 
 
On the Action tab, check the Enabled box to display the available actions tab bar. 
 

 
 
You can define actions to be performed whenever the alarm is activated using these 
different tabs. 
For example, if the alarm occurs, you can be notified by a sound, or receive an email alert 
with a customized message. 
 
Log 
 
The Log tab displays all alarm related events. 
 

 
 
The events are saved automatically as ‘.txt’ files to the Log folder, in your project directory.  

To open your project directory, click on the File menu and select Browse project directory. 
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3. Recipe 

 
 
The Recipe interface allows you to create, edit or execute your recipes. 
 
In Crystal XE, the recipes are made of a succession of layers. All the actions defined in a 
layer are executed at the beginning of the layer’s timer (temperature, opening the shutter, 
opening valve, etc.). The ramp duration can be defined over the layer’s duration or can be 
customized. 

3.1 Creating a new recipe 
 
You can edit a new recipe using either: 
 
 the recipe editor (graphical interface), 

or 
 the script editor (Pascal language). 

 

The recipe files can be accessed from the Recipe folder, in your project directory.  

To open your project directory, clicking on the File menu and select Browse project directory. 
 
In the recipe tab, you can also browse the recipe directory and preview the contents of those 
recipes. 
 

 

Browse directories 

Browse files 

Recipe overview 
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Graphical recipe editor 
 
Click on New recipe and New recipe (basic mode) to open the Main recipe editor. 
 

 
 

 
 

The Main recipe editor is a graphical interface allowing you to easily create your recipe.  
The created recipe is saved as a ‘.rcp’ file. 
 
 Click on the Script tab to display the recipe’s script. If you want to edit a recipe using 

the Script editor, use this tab to copy the script and paste it in the script editor 
(recommended): 
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 Creating your layers 
 

 
 
On the left side of the Main recipe editor window, you can create news layers, displayed in 
a tree structure. 
 
 Use the button  to add a layer or  or  to move the selected layer, or  to 

delete the selected layer. 
 Right-click on any of the layers to display other available options. 

 

 
 
For each layer, you can expand the list of equipment and associated parameters that have 
been defined: 
 

 
Example of a layer 
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 Defining the parameters 
 
In the center of the Main recipe editor window, the Properties tab displays all equipment 
and sub equipment and their associated configurable properties, listed in a tree view.  
 
For each layer, you can specify the layer duration, define a background color and then 
configure and add the desired parameters (properties) to the layer.  
 
Expand the equipment list and select the desired property to configure / add the 
parameters using the pane below. 
 
The configured parameters will be added to the layer in the tree structure on the left side of 
the editor window. 
 
 Conditional recipes 
 
It is possible to execute a layer only if a condition is true or wait for a condition is true 
before to continue.  
For more information, refer to the document “CrystalXE_conditional_recipes.pdf” available 
on http://ww.crystalxe.com/manuals 
 
 Uses variables in recipes 

 
The values used as setpoint for the cells or manipulator and all other values that is used 
as parameters can be either a constant value or a property or a variable. Click on the 
following button to open the data explorer: 
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 Graphical representation 
 

 

   
On the right side of the editor window, a graphical 
representation of the recipe allows you to view the 
chronological sequences (layers) and their time 
duration. 
 
 
By default, the substrate appears at the top and the 
layers are displayed from top to bottom, following a 
chronological order. 
 
 
You can invert this representation and display the 
substrate at the bottom by unchecking the Substrate on 

top box as follows:  
 

 
Script recipe editor 

 

 

Click on “New recipe” and “New script (advanced mode)” located in the 
top left-hand corner of the recipe interface, to open the Script editor. 
 

 

 

  
Use the Script editor to create a 
recipe using Pascal programming 
language. 
The created recipe is saved as a 
‘.pas’ file. 
 

 

3.2 Editing an existing recipe 
 

Click on Open/Edit  to edit a recipe file.  

You can also open the recipe file by clicking on the following file icon  and then 

clicking on the pencil icon  to open the recipe editor. 
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You can edit either ‘.pas’ files (edited with the script editor) or ‘.rcp’ files (edited with the 
recipe editor). 
Clicking on the following icon  clear the file name input field but does not delete the 
recipe file. 

3.3 Executing a recipe 

Click on the following icon  in the Recipe name input field to select the desired 
recipe file. 

Click on the Run button  . This will display a popup menu with two choices “Run 

now…” and “Run at...”. Clicking on “Run at...” allows you to start the recipe later. 

 If you choose to execute a batch at a predefined time you will have this window:  

 
 
As soon as you click on the Start time preselection button, the system starts counting 
down and executes the recipe at the fixed time. 
 

 
 Supervise the execution of the recipe using the Recipe inspector: 

 

 
 

 The Skip layer button  allows you to abort the ongoing layer and starts 
the execution of the next one 

 
 If the box ‘Start / Stop system recorder with recipe’ is checked, the data recorder will 

start recording as soon as the recipe starts executing and will stop when the recipe 
terminates. 

 



 
 

 ______________________________________________________________________________________  
Crystal XE - Getting started - rev 3 Page 37 of 48 
This document is Property of RIBER August 2019 

4. Charts 

The Charts tab allows you to easily follow the data using a chart view. Charts are 
generated automatically depending on your system configuration. 
 

 
 

Click on the Run button , in the top left-hand corner of the interface, to run the 

charts. A gray Run button  indicates that the charts are currently running. 

 Right-click on a chart to display the available options. 

  
 

  
 
 Charts are not saved automatically onto your hard disk. 

 

 On the left side of the interface, the following box allows you to 
display or hide a chart by clicking on it. 

 
The displayed charts are highlighted. 
 

 The charts record the data over the configured time duration. 
You can adjust the time duration using the scroll bar from the 
settings pane, located on the left side of the interface. 

 
You can increase the duration by increasing the acquisition time. 
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You can save a chart by right-clicking on the desired chart and Selecting File > Save as 
and then selecting the desired file format.  
 
You can save a chart as a CHR, CSV or image file.  
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5. Recorder (data logger) 

The recorder saves the main data onto the hard disk.  
 

 
The recorder window 

 

Click on the Record button to start recording.  

A grey Record button indicates that the system is currently recording.  
 
To automatically start the recorder when opening Crystal XE, go to the Options and in the 
chambers tab, change the “Recorder status” of the relative chamber to "Started". 
 

 If the check box  located in the Recipe interface, is 
checked, the recorder will start automatically as soon as a recipe starts executing and 
will stop when the recipe terminates. 

 

5.1 Saving the data 
The recorded data is saved as a ‘.csv’ file (text format) that can be accessed from the 
Record folder, in your project directory.  

To open your project directory, click on the File menu and select Browse project directory. 
 
Exporting data: 

 
 
Click on the CSV icon , located in the top right-hand corner of the recorder window, to 
copy the file onto your hard disk. You can save the data during or after recording. 
 

To open the recorded file, click on the spreadsheet icon . You can open the file even if 
the data is still being recorded.  
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5.2 Recorder templates 
 
On the Template drop-down menu, you can select either: 

 default template, 
or 
 custom template. 

 
 
The default template records all the main data while a custom template allows you to 
choose only specific data to be recorded. 
 

 Custom template is recommended in order to reduce the size of the generated file. 
 
You can run four different recorders at the same time. 
 
Creating a customized recorder template 
 
The customized template must be created before recording.  
 
Click on the New tab , from the recorder tab bar, to open the Record editor pop-up 
window and create a new customized template. 
 
The customized template is saved as a ‘.rec’. 
Template files can be accessed from your project directory > Record > Template.  

To open your project directory, click on the File menu and select Browse project directory. 
 
 
Opening a customized record template 
 
Click on the Add tab  and select the desired customized template file. 
 

Or, on the Template drop-down list, select Custom  and click on the file 
icon  below to open the desired customized template file.  

 
Editing a customized record template 
To edit an existing customized template file, click on the Open/Edit tab , from 
the recorder tab bar. Select the desired template file to open the Record editor pop-up 
window. 

Or click on the pencil icon  in the top left-hand corner of the recorder window. 
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6. Devices 

 
 
The Devices tab displays all the electronic devices that are able to communicate with 
Crystal XE and easily detect a communication or a connection problem. 
 
If the connection has failed, the following alert icon will appear over the device icon as 
follows: 
 

 
 
The absence of icon indicates that the connection has succeeded. 
 
Right-click on a device to display the available options: 

 analysing the connection to the device (select Analyser), 
 configuring the device (select Setup), 
 enabling / disabling the device (select Disable). 
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VII. PLATENS AUTOMATION 
 
The Automation tab allows you to create, edit or run production batches. The Automation 
feature is available only with the MBE systems that are equipped with a transportation 
system like a cluster or a pick and place (MBE49,6000,8000) 
 
In Crystal XE, a batch is used to organize the movements of one or more platens in the 
MBE system.  
For each platen, you can define its path to follow by selecting: 
 
 The first chamber, 
 One or several process chambers and at least one recipe to be executed in, 
 The last chamber. 

 
For each of these steps, you can also define the position of the platen in the cassette. 

1. Creating a new batch 

Click on the New batch button  to open the batch editor. 
 
Crystal XE asks you if the platen positions in the system must be loaded (unavailable in 
simulation mode). Select Yes (recommended) to open the Batch editor pop-up window. 
 
The batch is saved as a ‘.batch’ file that can be accessed in your project directory / Batch. 
To open the project directory, click on the File menu and select Browse project directory. 

2. Batch editor overview 

The platens are displayed in the following pane located on the left side of the Batch editor.  
 

 

 
 
 
 
 
Platens are assigned a default order (in parenthesis). 

 
You can change a platen order using the drop-down list in the Platen description box: 

 
 
The platen numbers must match those defined with the touch panel of the cluster PLC 
(Programmable Logic Controller). 
Select the desired platen (check the box) to define its path. 
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Platen path 
 

The path of the platen in the MBE system is composed of several configurable steps: 
 

 
 
In the example just above, the platen will move from the load chamber at position 1 to the degas chamber and it will execute 
the recipe test.rcp located in the Degas_chamber sub directory.  
When the recipe will be terminated, the platen will move to the growth chamber C21DZ and run the recipe HEMT growth.rcp.  
When the recipe will be terminated, the platen will move back to the load chamber at the same position. 
To optimize platens processing time then when a recipe is running, Crystal can move another tray to another location and run 
another recipe. 

 
For each step, select your choice from the corresponding drop-drop list: 
 
 Chamber (required) 

The platen will be dropped to this chamber. The list displays the chambers that are 
connected to the cluster only. 
 Position (required) 

The position in the cassette, if several platens can be stored in the chamber 
 Recipe (required for process chambers) 

The recipe to be executed in the selected chamber 
 Post recipe (optional)  

A second recipe will start as soon as the first recipe ends. 
 
 If the batch contains an error, a message warns you and the platen icon turns red as 

follows: 
 

 
 

Error examples: 
- no recipe selected when required 
- two platens start at the same position in the cassette 
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Batch properties 
Click on the Batch properties tab to display the configurable options of the Batch editor. 
 

 
 
Batch process options 
 

 
 
Limit the number of platens processed at the same 
time. 

By default, a maximum of platens is 
processed simultaneously. 
You can limit the number of platens to be 
processed at the same time by checking the 
following box and selecting the desired 
number 
 

Use a free position in a no process chamber (load, 
unload, etc..) for swapping. 

If two platens need to be dropped to the 
same chamber, you might need swapping 
the platens. 
Check this box to allow the cluster to swap 
platens to an auxiliary storage when 
needed. 
 

Wait for a platen to be present at the starting position 
(do not stop the batch) 

This option is useful when you want to 
perform continuous production. This allows 
the operator to unload the platen, reload 
another one and start the same path again. 
 

Wait if a platen is present at the destination (do not 
stop the batch) 

This option allows you to unload the platens 
always in the same place. 
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Editor options 
 

 
 
Start a path anywhere (even a process chamber) 
Terminate a path anywhere 

By default, a platen may not start or 
terminate its path in a growth chamber. 
Check either one or both boxes to allow the 
platens to start or/and terminate their path 
in any of the chambers 

Recipe is not necessary when platen is moved into a 
process chamber. 

By default, some chambers require at least 
one recipe to be defined. 
You can allow the batch to be executed 
even if no recipe has been defined by 
checking this box. 

Allow multiple path to start at the same position 
Allow multiple path to terminate at the same position 

These options are useful when you want to 
perform continuous production. 

 

3. Editing an existing batch 

Click on the Open/Edit button  and select the desired file. The file will open in 
the batch editor.  
Or you can click on the file icon  to open the desired file and then click on the pencil icon  to 
open it in the Batch editor. 
 

 
 
Clicking on the following icon  clears the Batch name file input field but doest not delete 
the batch file. 
 

4. Executing a batch 

On the Batch name file input field, click on the file icon  to open the desired batch file. 
 

 
 

Click on the Run button to start the batch.  
This will display a popup menu with two choices “Run now…” and “Run at...”. Clicking on 
“Run at...” allows you to start the recipe later. 
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During an ongoing movement, if you click either on Pause or Stop buttons, the platens will 
stop only once this movement has been completed. When paused, click on Resume to 
start the next movement. 
 
 If you choose to execute a batch at a predefined time you will have this window:  

 
 
As soon as you click on the Run button, the system starts counting down and executes the 
batch at the fixed time: 

 
 
 You can execute the same batch over and over by checking the Infinite batch box 

. The batch will automatically start again when all the platen will be 
completely terminated. Click on the Stop button to end the loop. 

 
 Select le choice  to restart automatically each platen path independently 

when it is completed. This choice is different from the infinite batch because it does 
not wait until the other platens are finished. 

 
 You can can monitor the execution of the recipe using the Recipe inspector window. 

On a process chamber column, click on desired platen and then click on the flask icon 
to open the Recipe inspector in a pop-up window.  
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 The Transport system log box displays history of the batch events. 
 

 
Batches related events are saved automatically in a text file as ‘.log’ file to the Log folder, in your project directory. 

 
 The chronogram displays in a table the different movements of the platens. Each 

column represents the movement of a platen from one position to another. 
 

 
Chronogram is saved automatically in a text file as ‘.csv’ files to the Log folder, in your project directory. 

 
 
To open your project directory, click on the File menu and select Browse project directory. 
 

 Click on the Info button  to open the Platens information pop-up window. 
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For each selected platen, the Platens information windows gives you the date and exact 
time the platen was dropped into a chamber and allow you to control whether the path was 
correctly executed. 
 
 
 
 


